Email field behaving differently

When I click on an email field in a record I get take to my gmail account. Previously a new email would open in my default email client.
I don’t use the gmail account for emails…why the change is there a setting??

This email field behavior hasn’t been changed for a while. What has most likely changed is the default email client setting on your browser.

Thank you for your reply.
I am on macs and I cant see where I change that setting

Try this
or this

Solved this - for some reason google chrome had made itself my default email reader.